Introduction
Un service d’export de rapports ne peut pas démarrer, car son petit fichier de configuration contient une valeur de port non valide. Le journal du service indique la plage de valeurs acceptées.
Le laboratoire guidé précédent vous a permis de mettre en pratique le même processus de récupération : vérifier l’état, consulter le journal, corriger une valeur de configuration, réinitialiser l’état d’échec, puis démarrer le service.
Remettre le service à l’état actif
Situation actuelle
labex-report-export.service est en échec. Il lit une affectation PORT dans /etc/labex-report-export.conf.
Périmètre
- Utilisez l’état du service et les informations du journal pour comprendre l’échec.
- Modifiez uniquement la valeur
PORTnon valide. - Choisissez un port numérique compris entre
1024et65535. - Ne modifiez ni le fichier d’unité ni les services sans rapport avec ce problème.
Objectif
Laissez labex-report-export.service à l’état actif avec un port configuré valide.
Critères de validation
systemctl is-active labex-report-export.servicerenvoieactive./etc/labex-report-export.confcontient une seule valeur numériquePORTcomprise dans la plage autorisée.
Indices
Par où commencer le diagnostic ?
Utilisez les mêmes commandes systemctl status et journalctl spécifiques à l’unité que celles utilisées dans le laboratoire guidé. Le message d’erreur indique ce qui n’est pas valide.
Résumé
Vous avez utilisé les informations du service pour corriger une valeur non valide et remettre une unité en échec en service.



